Monday, December 10, 2012

[How to] Config PPoE on Juniper SRX

Internet connections usually use PPoE (Point-to-Point Over Ethernet) technique. This configuration is not so complicated, here is what worked for me.

 In this example, I create the PPPoE interface pp0.0 and specify the logical Ethernet interface fe-0/0/7.0 as the underlying interface. I also set the access concentrator, set the PPPoE session parameters, and set the MTU of the IPv4 family to 1492.

interfaces pp0 {
description "PPPoE interface to Internet";
unit 0 {
ppp-options {
pap {
default-password "wxyz"; ## SECRET-DATA
local-name "user@service.com";
local-password "wxyz"; ## SECRET-DATA
passive;
}
}
pppoe-options {
underlying-interface fe-0/0/7.0;
idle-timeout 0;
auto-reconnect 5;
client;
}
family inet {
mtu 1492;
negotiate-address;
}
}

}

Here is the “set” format:


set interfaces pp0 description "PPPoE interface to Internet"
set interfaces pp0 unit 0 ppp-options pap default-password "wxyz"
set interfaces pp0 unit 0 ppp-options pap local-name "user@service.com"
set interfaces pp0 unit 0 ppp-options pap local-password "wxyz"
set interfaces pp0 unit 0 ppp-options pap passive
set interfaces pp0 unit 0 pppoe-options underlying-interface fe-0/0/7.0
set interfaces pp0 unit 0 pppoe-options idle-timeout 0
set interfaces pp0 unit 0 pppoe-options auto-reconnect 5
set interfaces pp0 unit 0 pppoe-options client
set interfaces pp0 unit 0 family inet mtu 1492
set interfaces pp0 unit 0 family inet negotiate-address

set routing-options static route 0.0.0.0/0 next-hop pp0.0
set security zones security-zone untrust interfaces pp0.0 


Verify PPoE operation
user@host> show interfaces pp0
user@host> show pppoe statistics 
 

No comments:

Post a Comment